phone_auth_simple 1.0.0
phone_auth_simple: ^1.0.0 copied to clipboard

A Flutter Package to do Phone Authentication in just one simple step.

6
likes
40 / 130
pub points
29 %
popularity

We analyzed this package on May 13, 2021, and awarded it 40 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 12 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:phone_auth_simple/phone_auth_simple.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

ERROR: The named parameter 'resizeToAvoidBottomPadding' isn't defined.

lib/phone_auth_simple.dart:273:7

    ╷
273 │       resizeToAvoidBottomPadding: false,
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/phone_auth_simple.dart

ERROR: The named parameter 'resizeToAvoidBottomPadding' isn't defined.

lib/src/phone_auth_otp.dart:244:7

    ╷
244 │       resizeToAvoidBottomPadding: false,
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/phone_auth_otp.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_auth^0.6.60.6.61.1.4
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
firebase_core-0.2.5+11.1.1
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.6` on firebase_auth does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.68.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

6
likes
40
pub points
29%
popularity

A Flutter Package to do Phone Authentication in just one simple step.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

kadarsh.singh@gmail.com

License

LICENSE

Dependencies

firebase_auth, flutter

More

Packages that depend on phone_auth_simple