Ini adalah percobaan untuk publish package Dart
membuat paket Dart
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: petanikode: ^0.0.2
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.1
- pana: 0.13.6
Analysis issues and suggestions
Fix dependencies in
pub upgrade failed with the following output:
ERR: The current Dart SDK version is 2.7.1. Because petanikode requires SDK version >=1.8.0 <2.2.0, version solving failed.
Maintenance issues and suggestions
Support future stable Dart 2 SDKs in
pubspec.yaml. (-20 points)
The SDK constraint in
pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.
No valid SDK. (-20 points)
The analysis could not detect a valid SDK that can use this package.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
|Dart SDK||>=1.8.0 <2.2.0|