osproxysetting 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 45

osproxysetting #

A new Flutter plugin to fetch os proxy setting.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Usage #

U can use this plugin to fetch system proxy settings. And can set HttpClient's findProxy method, so that u can use Charles(or other tools) to wireshark.

Example in use dio in Flutter or other libary use HttpCilent.

First, add dependency to your pubspec.yaml

osproxysetting: ^0.0.1

Then set findProxy function.

if (_debugMode) {
    (_dio.httpClientAdapter as DefaultHttpClientAdapter).onHttpClientCreate =
        (client) async {
    client.findProxy = (uri) {
        final setting = OsProxySetting.cacheSetting();
        if (setting == null ||
            !setting.httpEnable ||
            setting.port == null ||
            setting.host == null) {
        return "DIRECT";
        }
        return "PROXY ${setting.host}:${setting.port}";
    };
    };
}

0.0.1 #

  • TODO: Describe initial release.

0.0.2 #

  • fix cache time error

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:osproxysetting/os_proxy_settings.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      final settings = await OsProxySetting.settings;
      platformVersion = "$settings";
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('Running on: $_platformVersion\n'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  osproxysetting: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:osproxysetting/os_proxy_settings.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
77
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:osproxysetting/os_proxy_settings.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:osproxysetting/os_proxy_settings.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:osproxysetting/os_proxy_settings.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:osproxysetting/os_proxy_settings.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [osproxysetting] that is in a package requiring null.

Health suggestions

Fix lib/os_proxy_settings.dart. (-0.50 points)

Analysis of lib/os_proxy_settings.dart reported 1 hint:

line 6 col 16: The value of the field 'httpsEnable' isn't used.

Maintenance suggestions

The package description is too short. (-13 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test