oauth_twitter 0.0.7 icon indicating copy to clipboard operation
oauth_twitter: ^0.0.7 copied to clipboard

The OAuth library for twitter API.

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
10 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 42 API elements (45.2 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:oauth_twitter/oauth_twitter.dart that imports:
  • package:oauth_twitter/src/oauth_db_sqlite.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:oauth_twitter/oauth_twitter.dart that imports:
  • package:oauth_twitter/src/oauth_db_sqlite.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:oauth_twitter/oauth_twitter.dart that imports:
  • package:oauth_twitter/src/oauth_db_sqlite.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: The variable name 'oauth_token' isn't a lowerCamelCase identifier.

lib/oauth_twitter.dart:83:12

   ╷
83 │     String oauth_token = "";
   │            ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/oauth_twitter.dart

INFO: 'canLaunch' is deprecated and shouldn't be used. Use canLaunchUrl instead.

lib/oauth_twitter.dart:157:13

    ╷
157 │       await canLaunch(url) ? await launch(url) : throw 'Could not launch $url';
    │             ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/oauth_twitter.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^3.0.13.0.23.0.2
flutterflutter0.0.00.0.0
path^1.8.01.8.31.8.3
sqflite^2.0.0+32.2.4+12.2.4+1
test^1.5.11.22.21.22.2
url_launcher^6.0.96.1.86.1.8
uuid^3.0.43.0.73.0.7
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-52.0.052.0.0
analyzer-5.4.05.4.0
args-2.3.22.3.2
async-2.10.02.10.0
boolean_selector-2.1.12.1.1
characters-1.2.11.2.1
collection-1.17.01.17.1
convert-3.1.13.1.1
coverage-1.6.21.6.2
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
frontend_server_client-3.2.03.2.0
glob-2.1.12.1.1
http_multi_server-3.2.13.2.1
http_parser-4.0.24.0.2
io-1.0.41.0.4
js-0.6.50.6.7
logging-1.1.11.1.1
matcher-0.12.140.12.14
material_color_utilities-0.2.00.2.0
meta-1.8.01.8.0
mime-1.0.41.0.4
node_preamble-2.0.12.0.1
package_config-2.1.02.1.0
plugin_platform_interface-2.1.32.1.3
pool-1.5.11.5.1
pub_semver-2.1.32.1.3
shelf-1.4.01.4.0
shelf_packages_handler-3.0.13.0.1
shelf_static-1.1.11.1.1
shelf_web_socket-1.0.31.0.3
sky_engine-0.0.990.0.99
source_map_stack_trace-2.1.12.1.1
source_maps-0.10.110.10.11
source_span-1.9.11.9.1
sqflite_common-2.4.2+22.4.2+2
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
string_scanner-1.2.01.2.0
synchronized-3.0.13.0.1
term_glyph-1.2.11.2.1
test_api-0.4.180.4.18
test_core-0.4.220.4.22
typed_data-1.3.11.3.1
url_launcher_android-6.0.236.0.23
url_launcher_ios-6.0.186.0.18
url_launcher_linux-3.0.23.0.2
url_launcher_macos-3.0.23.0.2
url_launcher_platform_interface-2.1.12.1.1
url_launcher_web-2.0.142.0.14
url_launcher_windows-3.0.33.0.3
vector_math-2.1.42.1.4
vm_service-10.1.210.1.2
watcher-1.0.21.0.2
web_socket_channel-2.3.02.3.0
webkit_inspection_protocol-1.2.01.2.0
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

0
likes
100
pub points
0%
popularity

Publisher

unverified uploader

The OAuth library for twitter API.

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

crypto, flutter, path, sqflite, test, url_launcher, uuid

More

Packages that depend on oauth_twitter