nearby_connectivity 0.0.5

A Flutter plugin built on top of Nearby Connections and Multipeer Connectivity. iOS side under development Currently only P2P_CLUSTER strategy is supported

Following example automatically connects two devices.

Start advertising

NearbyConnectivity.startAdvertising(name: name, idService: idService).listen((advertise) {
  switch (advertise.type) {
    case TypeLifecycle.initiated:
      acceptConnection(advertise);
      // you are now connected
      break;
    case TypeLifecycle.result:
      break;
    case TypeLifecycle.disconnected:
        // you are now disconnected
      break;
  }
});

Start discovering

NearbyConnectivity.startDiscovering(idService: idService).listen((discovery) {
  switch (discovery.type) {
    case TypeDiscovery.found:
      requestConnection(discovery);
      break;
    case TypeDiscovery.lost:
      break;
  }
});


Request connection using the discovery object

NearbyConnectivity.requestConnection(idEndpoint: discovery.idEndpoint).listen((lifecycle) {
  switch (lifecycle.type) {
    case TypeLifecycle.initiated:
      acceptConnection(lifecycle, isDiscoverer: true);
      // you are now connected
      break;
    case TypeLifecycle.result:
      break;
    case TypeLifecycle.disconnected:
      // you are now disconnected
      break;
  }
});

Accept connection using the advertise object

NearbyConnectivity.acceptConnection(idEndpoint: advertise.idEndpoint).listen((payload) {
  switch (payload.type) {
    case TypePayload.received:
      // payload received
      break;
    case TypePayload.transferred:
      // payload being transferred
      break;
  }
});

Send payload

Nearby.sendPayloadBytes(idEndpoint: connection.idEndpoint, bytes: bytesPayload);

0.0.1 #

  • Initial release

0.0.2 #

  • Adds sample code in README.md

0.0.3 #

  • Updates CHANGELOG.md

0.0.4 #

  • Adds github link and description

0.0.5 #

  • Adds sample code in README.md

example/README.md

nearby_connectivity_example #

Demonstrates how to use the nearby_connectivity plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  nearby_connectivity: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:nearby_connectivity/nearby_connectivity.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
77
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

61 out of 61 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/nearby_connectivity.dart. (-1.99 points)

Analysis of lib/nearby_connectivity.dart reported 4 hints:

line 87 col 9: Close instances of dart.core.Sink.

line 100 col 9: Close instances of dart.core.Sink.

line 113 col 9: Close instances of dart.core.Sink.

line 126 col 9: Close instances of dart.core.Sink.

Maintenance suggestions

The package description is too short. (-13 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test