naumen_smp_jsapi 1.1.9

  • Readme
  • Changelog
  • Example
  • Installing
  • 49

naumen_smp_jsapi #

Вспомогательная библиотека для разработки встраиваемых приложений Naumen SMP на Dart.

Использование #

Простой пример использования:

import 'package:naumen_smp_jsapi/naumen_smp_jsapi.dart';

main() {
  print('Приложение встроено на карточку с UUID: ${JsApi.extractSubjectUuid()}');
  print('Код контента приложения: ${JsApi.findContentCode()}');
}

Замечания и предложения #

Вы можете оставлять свои замечания и предложения в трекер этого репозитория.

1.0.0 #

  • Initial version, created by Stagehand

1.0.3 #

  • Update SMP methods, check types

1.1.0 #

  • Add JS interop methods

1.1.0 #

  • Add JS interop methods and classes
  • Mark old methods as deprecated

1.1.6 #

  • Change description

example/naumen_smp_jsapi_example.dart

import 'package:naumen_smp_jsapi/naumen_smp_jsapi.dart';

main() {
  print('Приложение встроено на карточку с UUID: ${JsApi.extractSubjectUuid()}');
  print('Код контента приложения: ${JsApi.findContentCode()}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  naumen_smp_jsapi: ^1.1.9

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:naumen_smp_jsapi/naumen_smp_jsapi.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Health suggestions

Fix lib/src/naumen_smp_jsapi.dart. (-1.99 points)

Analysis of lib/src/naumen_smp_jsapi.dart reported 4 hints:

line 2 col 9: Name libraries using lowercase_with_underscores.

line 209 col 32: Unnecessary new keyword.

line 218 col 14: Use isNotEmpty instead of length

line 457 col 39: This function has a return type of 'bool', but doesn't end with a return statement.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0 < 3.0.0
http ^0.12.0 0.12.0+2
js ^0.6.0 0.6.1+1
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
http_parser 3.1.3
meta 1.1.8
path 1.6.4
pedantic 1.9.0
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
test ^1.0.0