my_easy_dialogs 0.1.5
my_easy_dialogs: ^0.1.5

Flutter Android iOS web

This package will simplify your life by letting you create responsive dialogs the easiest way possible.

4
likes
100 / 110
pub points
46 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 8 API elements (25.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/dialogs/my_easy_dialog.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
get_platform^0.0.20.0.30.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

4
likes
100
pub points
46%
popularity

This package will simplify your life by letting you create responsive dialogs the easiest way possible.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

simon.braillard@gmail.com

License

BSD (LICENSE)

Dependencies

flutter, get_platform

More

Packages that depend on my_easy_dialogs