music_volume 0.0.5

  • Readme
  • Changelog
  • Example
  • Installing
  • 60

music_volume #

This package is a plugin to change the volume.

Only Support android.media.AudioManager.STREAM_MUSIC, so very simple package.

Using #

var _currentVolume = await MusicVolume.currentVolume;
var _maxVolume = await MusicVolume.maxVolume;
var _isMute = await MusicVolume.isMute;
await  MusicVolume.changeVolume(_maxVolume, 0);

// ・・・ playing music logic

await  MusicVolume.changeVolume(_currentVolume, _isMute);

0.0.1 - 0.0.3 #

  • test release It does not work.

0.0.4 #

Implement the following as a minimum function

  • get max volume value
  • get current volume value
  • get mute state
  • set volume and mute

0.0.5 #

I wrote the document seriously. There are no implementation changes.

example/README.md

music_volume_example #

Demonstrates how to use the music_volume plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  music_volume: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:music_volume/music_volume.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
33
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Format lib/music_volume.dart.

Run flutter format to format lib/music_volume.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test