moonshade 0.0.2

Moonshade Dart Packages #

example/main.dart

import 'dart:async';
import 'dart:core';
import 'dart:convert';
import 'dart:io';
import 'package:http/http.dart' as http;
import 'package:moonshade/moonshade.dart' as ms;

Future<Null> main() async {
  var client = ms.Client('localhost', 50051, 'anonymous', 'anonymous');
  var data =
      (await http.get('https://www.imdb.com/chart/top?ref_=nv_mv_250')).body;
  var titleRe = new RegExp("([^<>]*)</a>\n        <s");
  var titleList = titleRe.allMatches(data).toList();
  var yearRe = new RegExp("\">\\(([0-9]*)");
  var yearList = yearRe.allMatches(data).toList();
  var rateRe = new RegExp("(...) bas");
  var rateList = rateRe.allMatches(data).toList();
  for (var i = 0; i != 250; ++i) {
    var title = titleList[i].group(1);
    var year = int.parse(yearList[i].group(1));
    var rate = double.parse(rateList[i].group(1));
    await client.insertOne(
        "imdb",
        "moonshade",
        "imdb",
        new JsonEncoder()
            .convert({"Title": title, "Year": year, "Rate": rate}));
  }
  client.shutdown();
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  moonshade: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:moonshade/moonshade.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <2.0.0

Admin