mongo_dart_query 0.3.1

  • Readme
  • Changelog
  • Installing
  • 29

mongo_dart_query #

Build Status

Query builder for mongo_dart

0.3.1 - June 30th, 2018 (@thosakwe, @aemino) #

  • Merged PR #11 from @aemino, which adds Dart 2 fixes for this package, namely coercin of generic types avoiding implicit casts.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mongo_dart_query: ^0.3.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mongo_dart_query/mongo_dart_query.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
59
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
29
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.10.0 <2.0.0