monads 0.0.1

A library for Dart developers.

Usage #

See examples

Features and bugs #

1.0.0 #

  • Initial version, created by Stagehand

example/monads_example.dart

import 'package:monads/monads.dart';

main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  monads: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:monads/monads.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
20
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:monads/monads.dart.

Health suggestions

Fix lib/src/maybe.dart. (-5.84 points)

Analysis of lib/src/maybe.dart reported 12 hints, including:

line 1 col 22: Use lowercase_with_underscores when specifying a library prefix.

line 2 col 25: Use lowercase_with_underscores when specifying a library prefix.

line 10 col 3: Prefer using /// for doc comments.

line 18 col 3: Prefer using /// for doc comments.

line 25 col 3: Prefer using /// for doc comments.

Fix lib/src/result.dart. (-3.45 points)

Analysis of lib/src/result.dart reported 7 hints, including:

line 1 col 6: Don't explicitly initialize variables to null.

line 11 col 1: Prefer using /// for doc comments.

line 17 col 62: Don't explicitly initialize variables to null.

line 17 col 71: Use = to separate a named parameter from its default value.

line 44 col 3: Prefer using /// for doc comments.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
Dev dependencies
test ^1.0.0

Admin