modular_permission_location 0.1.0
modular_permission_location: ^0.1.0 copied to clipboard

Location permission plugin to be used with Modular Permissions.

1
likes
105/ 130
pub points
0%
popularity

We analyzed this package on Sep 23, 2021, and awarded it 105 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:17:73

   ╷
17 │ <p><code>modular_permission_location</code> is maintained and funded by <a href="http://upte.ch/">UpTech Works, LLC</a>, a
   │                                                                         ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

Links in `README.md` should be secure. 1 image link is insecure.

README.md:16:11

   ╷
16 │ <h2>About <img src="http://upte.ch/img/logo.png" width="180"></h2>
   │           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

1
likes
105
pub points
0%
popularity

Publisher

upte.ch

Location permission plugin to be used with Modular Permissions.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on modular_permission_location