mml_dart 1.0.0

  • Installing
  • Versions
  • 0

MML - Dart #

This library is designed to be used for parsing MML (Music Macro Language) Files

More will be added soon

Valid MML is based off Nullsleep's guide to MCK and the MIR MML Specs here

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  mml_dart: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:mml_dart/mml_dart.dart';
Version Uploaded Documentation Archive
1.0.0 Nov 23, 2016 Go to the documentation of mml_dart 1.0.0 Download mml_dart 1.0.0 archive
0.0.3 Nov 22, 2016 Go to the documentation of mml_dart 0.0.3 Download mml_dart 0.0.3 archive
0.0.2 Nov 18, 2016 Go to the documentation of mml_dart 0.0.2 Download mml_dart 0.0.2 archive
0.0.1 Nov 17, 2016 Go to the documentation of mml_dart 0.0.1 Download mml_dart 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.