message_builder 0.1.3+1

  • Readme
  • Changelog
  • Installing
  • 1

message_builder #

Generate serializable Dart classes from a schema

0.1.3+1 #

  • Allow package:build version 0.12.x.

0.1.3 #

  • Upgrade to code_builder version 3.0
  • Add default for generate_for to avoid applying to pubspec.yaml by default.

0.1.2 #

  • Handle keys explicitly set to null as if they were missing.

0.1.1 #

  • Add a build.yaml so this builder can be used with build_runner v0.7.0

0.1.0 #

  • Initial version. Extracted from dart_language_server
  • Refactor to use code_builder.
  • Add support for Map type fields.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  message_builder: ^0.1.3+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:message_builder/message_builder.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0