meiqiachat 1.0.2

meiqiachat #

美洽客服移动sdk3.5.8 接入 适配iOS、android 针对工作上需求会酌情继续 添加相应功能 如有交流敬请邮箱联系loselfmin@gmail.com

实现功能 1、初始化sdk 2、启动对话页面

iOS 真机如果出现语言没有跟随系统可以添加

<key>CFBundleLocalizations</key>
<array>
    <string>zh_CN</string>
    <string>zh_TW</string>
    <string>en</string>
</array>

到info.plist中

简单使用 #

1、初始化sdk 在项目 main.dart 初始化时候初始化

 @override
  void initState() {
    super.initState();
    initMeiqia();
  }

  Future<void> initMeiqia() async {
    try {
      await Meiqiachat.initMeiqiaSdkWith(
          appkey);
    } catch (e) {}
  }

2、启动聊天页面

void _toChat() async{
    try {
        <!-- isPush 为iOS的跳转状态 默认为present -->
        await Meiqiachat.toChat(isPush: true);
    } catch (e){}
}

1.0.2 #

  • 首次创建plugin并上传,针对flutter技术还在探索学习中,本次集成的是美洽3.5.8,如果时间允许会进一步跟进sdk的其他功能集成,本次集成只实现了项目的初始化和跳转客服聊天页面。如果有同样需求的朋友可以自行去官网查看https://www.meiqia.com后续的sdk功能。

example/README.md

meiqiachat #

美洽客服移动sdk3.5.8 接入 适配iOS、android 针对工作上需求会酌情继续 添加相应功能 如有交流敬请邮箱联系loselfmin@gmail.com

实现功能 1、初始化sdk 2、启动对话页面

iOS 真机如果出现语言没有跟随系统可以添加

<key>CFBundleLocalizations</key>
<array>
    <string>zh_CN</string>
    <string>zh_TW</string>
    <string>en</string>
</array>

到info.plist中

简单使用 #

1、初始化sdk 在项目 main.dart 初始化时候初始化

 @override
  void initState() {
    super.initState();
    initMeiqia();
  }

  Future<void> initMeiqia() async {
    try {
      await Meiqiachat.initMeiqiaSdkWith(
          appkey);
    } catch (e) {}
  }

2、启动聊天页面

void _toChat() async{
    try {
        <!-- isPush 为iOS的跳转状态 默认为present -->
        await Meiqiachat.toChat(isPush: true);
    } catch (e){}
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  meiqiachat: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:meiqiachat/meiqiachat.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
23
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Sep 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/meiqiachat.dart.

Run flutter format to format lib/meiqiachat.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test