material_switch 0.0.9

A new flutter package project.

1
likes
20 / 110
pub points
69 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 20 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Sdk-constraint doesn't allow future stable dart 2.x releases

pubspec.yaml:16:8

   ╷
16 │   sdk: ">=1.19.0 <2.1.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 58 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:flutter/material.dart'.

lib/material_switch.dart:3:8

  ╷
3 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/material_switch.dart

ERROR: Classes can only extend other classes.

lib/material_switch.dart:5:30

  ╷
5 │ class MaterialSwitch extends StatefulWidget {
  │                              ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/material_switch.dart

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.9.3. Cannot run `pub outdated`.

pubspec.yaml:16:8

   ╷
16 │   sdk: ">=1.19.0 <2.1.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

The current sdk constraint does not allow the latest stable Dart (2.9.3)

pubspec.yaml:16:8

   ╷
16 │   sdk: ">=1.19.0 <2.1.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (2.9.2)

pubspec.yaml:16:8

   ╷
16 │   sdk: ">=1.19.0 <2.1.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵