magpie_fly 0.0.1

Flutter Android iOS web

magpie_fly

0
likes
55 / 110
pub points
0 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 55 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

  • Homepage URL isn't helpful.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 163 API elements (19.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Unused import: 'dart:async'.

lib/magpie_fly.dart:1:8

  ╷
1 │ import 'dart:async';
  │        ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/magpie_fly.dart

INFO: 'inheritFromWidgetOfExactType' is deprecated and shouldn't be used. Use dependOnInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

lib/src/banner/banner_round.dart:148:20

    ╷
148 │     return context.inheritFromWidgetOfExactType(_InheritedWidget);
    │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/banner/banner_round.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
provider^3.1.0+13.2.04.3.2+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.1.0+1` on provider does not support the latest published version `4.3.2+2`

pubspec.yaml:12:13

   ╷
12 │   provider: ^3.1.0+1
   │             ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
55
pub points
0%
popularity

magpie_fly

Homepage

Documentation

API reference

Uploader

liyixin0224@gmail.com

License

unknown (LICENSE)

Dependencies

flutter, provider

More

Packages that depend on magpie_fly