magpie_fly 0.0.1

  • Readme
  • Changelog
  • Installing
  • new42

magpie_fly #

一个UI组件库。

组件清单 #

组件说明
视频滚动检测播放控件用于视频列表的滚动检测和播放控制
安全区吸顶组件Sliver状态栏安全区吸顶
全屏拖动按钮可用于右下角的广告位
尾部弹性ScrollView一个支持滑动回弹加载更多的组件
popup_window一个支持任意方向上的popwindow
搜索组件提供常用带阴影和不带阴影的搜索组件

0.0.1 #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  magpie_fly: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:magpie_fly/magpie_fly.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
42
Learn more about scoring.

We analyzed this package on Jan 18, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/magpie_fly.dart. (-0.50 points)

Analysis of lib/magpie_fly.dart reported 1 hint:

line 1 col 8: Unused import: 'dart:async'.

Fix lib/src/banner/banner_round.dart. (-0.50 points)

Analysis of lib/src/banner/banner_round.dart reported 1 hint:

line 148 col 20: 'inheritFromWidgetOfExactType' is deprecated and shouldn't be used. Use dependOnInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

Fix lib/src/popup_window/popup_window.dart. (-0.50 points)

Analysis of lib/src/popup_window/popup_window.dart reported 1 hint:

line 3 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: PopupWindow.window, PopupWindow.popKey, PopupWindow.popDirection, PopupWindow.popWidget, PopupWindow.offset

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/feed/scroll_detect_listener.dart (Run flutter format to format lib/src/feed/scroll_detect_listener.dart.)
  • lib/src/horizontal_scroll/footer_view.dart (Run flutter format to format lib/src/horizontal_scroll/footer_view.dart.)
  • lib/src/horizontal_scroll/horizontal_scroll.dart (Run flutter format to format lib/src/horizontal_scroll/horizontal_scroll.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (provider).

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and magpie_fly.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
provider ^3.1.0+1 3.2.0 4.0.2
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test