magic 0.0.1

Magic #

A new magical flutter package.

Features #

  • Application container
  • Environments
  • Auth
  • API base HTTP
  • Model
  • Controller
  • And much more...

Version compatability #

See CHANGELOG for all breaking (and non-breaking) changes.

Getting started #

The magic package has special structure. So, you need to start your project by using the magic repository.

Clone the repository

Go to path

Run the flutter

## Example Project

There is a pretty sweet example project in the `example` folder. Check it out. Otherwise, keep reading to get up and running.

## Documents

The documents about the magic will be in the [wiki page]( of the repository.

[0.0.1] - Initial

  • The package initial completed.


import 'package:app/config/app.dart';
import 'package:magic/magic.dart';

main() {
  new Magic().boot(config: appConfig, environment: {
    'app.env': 'development',
    'api.url': 'http://localhost:8000/api/'

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  magic: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:magic/magic.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0