m4d_core 0.1.15

Material4Dart Core package #

For more - check out these packages:

Change Log for m4d_core #

Material Design 4 Dart

Unreleased #

Feature #

  • IOC-Container can register Events 1b090bf
  • Added some DOM-Helper functions bfac090
  • Added ObservableProperty and ObservableList 7e0120a
  • ObservableProperty added 6e0f459

Docs #

This CHANGELOG.md was generated with Changelog for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  m4d_core: ^0.1.15

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:m4d_core/m4d_core.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
81
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Jul 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: web

Primary library: package:m4d_core/m4d_core.dart with components: html, js.

Health suggestions

Fix lib/core/MdlComponentHandler.dart. (-3.93 points)

Analysis of lib/core/MdlComponentHandler.dart reported 8 hints, including:

line 73 col 1: Prefer using /// for doc comments.

line 117 col 5: Prefer using /// for doc comments.

line 139 col 5: Prefer using /// for doc comments.

line 254 col 56: Use = to separate a named parameter from its default value.

line 266 col 52: Use = to separate a named parameter from its default value.

Fix lib/observable/ObservableProperty.dart. (-3.45 points)

Analysis of lib/observable/ObservableProperty.dart reported 7 hints, including:

line 70 col 5: Prefer using /// for doc comments.

line 91 col 26: Use = to separate a named parameter from its default value.

line 91 col 88: Use = to separate a named parameter from its default value.

line 92 col 37: Use = to separate a named parameter from its default value.

line 122 col 5: Avoid return types on setters.

Fix lib/core/MdlComponent.dart. (-2.48 points)

Analysis of lib/core/MdlComponent.dart reported 5 hints:

line 37 col 5: Prefer using /// for doc comments.

line 91 col 66: Use = to separate a named parameter from its default value.

line 115 col 28: Use = to separate a named parameter from its default value.

line 116 col 32: Use = to separate a named parameter from its default value.

line 161 col 13: Use rethrow to rethrow a caught exception.

Fix additional 15 files with analysis or formatting issues. (-10.96 points)

Additional issues in the following files:

  • lib/core/interfaces.dart (4 hints)
  • lib/core/dom/DataAttibute.dart (3 hints)
  • lib/m4d_utils.dart (3 hints)
  • lib/observable/ObservableList.dart (3 hints)
  • lib/core/DomRenderer.dart (2 hints)
  • lib/core/MdlConfig.dart (2 hints)
  • lib/core/utils.dart (2 hints)
  • lib/core/annotations.dart (1 hint)
  • lib/m4d_core.dart (1 hint)
  • lib/utils/StringToFunction.dart (1 hint)
  • lib/core/MdlEventListener.dart (Run dartfmt to format lib/core/MdlEventListener.dart.)
  • lib/core/dom/ElementProperties.dart (Run dartfmt to format lib/core/dom/ElementProperties.dart.)
  • lib/m4d_ioc.dart (Run dartfmt to format lib/m4d_ioc.dart.)
  • lib/services.dart (Run dartfmt to format lib/services.dart.)
  • lib/utils/ConvertValue.dart (Run dartfmt to format lib/utils/ConvertValue.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and m4d_core.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
console_log_handler ^1.0.0 1.1.6
l10n ^2.0.0 2.0.19
logging >=0.11.3 <1.0.0 0.11.3+2
path ^1.4.0 1.6.2
platform_detect ^1.3.0 1.3.5
validate ^1.0.0 1.7.0
Transitive dependencies
analyzer 0.36.4 0.37.0
ansicolor 1.0.2
async 2.2.0
build_cli_annotations 1.1.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.16.1
dart_style 1.2.9
front_end 0.1.19 0.1.20
glob 1.1.7
html 0.14.0+2
intl 0.15.8
intl_translation 0.17.5
kernel 0.3.19 0.3.20
meta 1.1.7
optional 3.0.2+1
package_config 1.0.5
petitparser 2.4.0
pub_semver 1.4.2
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+10
where 4.4.0 6.3.0
yaml 2.1.16
Dev dependencies
args any 1.5.2
build_runner any
build_test any
build_web_compilers any
test any

Admin