loose 0.1.0-nullsafety.0 icon indicating copy to clipboard operation
loose: ^0.1.0-nullsafety.0 copied to clipboard

Library for working with Google Cloud Firestore in a server application.

0
likes
95/ 140
pub points
0%
popularity

We analyzed this package 11 days ago, and awarded it 95 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
25 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

README.md is empty.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 286 API elements (2.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:loose/loose.dart that imports:
  • package:loose/src/write/write.dart that imports:
  • package:loose/src/loose.dart that imports:
  • package:googleapis_auth/auth_io.dart that imports:
  • package:googleapis_auth/src/oauth2_flows/authorization_code_grant_server_flow.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
10 / 30icon to trigger folding of the section

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 40 issues. Showing the first 2:

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/src/query/query.dart:22:36

   ╷
22 │             request.document.parent?.parent?.resolvePath(idPath) ?? '';
   │                                    ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/query/query.dart

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/src/query/query.dart:31:46

   ╷
31 │       structuredQuery.addAll({'where': filter?.encode() ?? const {}});
   │                                              ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/query/query.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
googleapis_auth^1.1.01.3.11.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
collection-1.17.01.17.0
crypto-3.0.23.0.2
http-0.13.50.13.5
http_parser-4.0.24.0.2
meta-1.8.01.8.0
path-1.8.31.8.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.0.

0
likes
95
pub points
0%
popularity

Publisher

unverified uploader

Library for working with Google Cloud Firestore in a server application.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

googleapis_auth

More

Packages that depend on loose