loginscreenkt 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • new44

loginscreenkt #

A new Flutter plugin.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.2 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'dart:async';

import 'package:flutter/material.dart';
import 'package:loginscreenkt/loginscreenkt.dart';


void main() {
  runApp(LoginScreen());
}

class LoginScreen extends StatefulWidget {
  @override
  _LoginScreen1State createState() => new _LoginScreen1State();
}

class _LoginScreen1State extends State<LoginScreen> {
  
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'LoginScreen Example',
      theme: ThemeData(
        primarySwatch: Colors.blue,
        visualDensity: VisualDensity.adaptivePlatformDensity,
      ),
      onGenerateRoute: (settings) {
        if (settings.name == '\home')
          return MaterialPageRoute(
            builder: (context) => Scaffold(
              body: Center(child: Text("Home")),
            ),
          );

        return MaterialPageRoute(
          builder: (context) => Loginscreenkt(
           backgroundColor: Colors.blue.shade600,
          //  background: Container
          //  (child: Image.asset('assets/splash.jpeg',
          //    fit: BoxFit.cover),),
            showErrortext : false,
           // asset: 'assets/apple.png',
            authenticator: (login, pass) {
              print(login);
              print(pass);
              return true;
            },
            nextRoute: '\home',
            rememberOption: true,
            onRemember: (_) => print('remember'),
            duration: 3000,
          ),
        );
      },
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  loginscreenkt: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:loginscreenkt/loginscreenkt.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:loginscreenkt/loginscreenkt.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:loginscreenkt/loginscreenkt.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:loginscreenkt/loginscreenkt.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:loginscreenkt/loginscreenkt.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • loginscreenkt that is a package requiring null.

Health suggestions

Fix lib/loginscreenkt.dart. (-0.50 points)

Analysis of lib/loginscreenkt.dart reported 1 hint:

line 6 col 7: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: Loginscreenkt.showErrortext

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test