lodash_dart 0.0.7
lodash_dart: ^0.0.7 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A lodash package in dart for flutter developer to make their life easier and implementing algorithm in their app much more interesting.

5
likes
80 / 110
pub points
51 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 27 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Avoid using unnecessary statements.

lib/lodash_dart.dart:195:47

    ╷
195 │     result.isEmpty ? goInDeep(array: array) : null;
    │                                               ^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/lodash_dart.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
meta-1.3.0-nullsafety.31.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

5
likes
80
pub points
51%
popularity

A lodash package in dart for flutter developer to make their life easier and implementing algorithm in their app much more interesting.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

kadarsh.singh@gmail.com

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on lodash_dart