location_context 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 16

location_context #

Build Status

Helper functions to share location data using InheritedWidgets

This plugin is also available on pub

Getting Started #

For help getting started with Flutter, view our online documentation. You can also visit us at Flutter Institute

For help on editing package code, view the documentation.

[1.0.0] - 2018-07-17

  • Initial release for sharing location data using InheritedWidget

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  location_context: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:location_context/location_context.dart';
  
Version Uploaded Documentation Archive
1.0.3+1 Aug 24, 2018 Go to the documentation of location_context 1.0.3+1 Download location_context 1.0.3+1 archive
1.0.3 Aug 24, 2018 Go to the documentation of location_context 1.0.3 Download location_context 1.0.3 archive
1.0.2 Aug 4, 2018 Go to the documentation of location_context 1.0.2 Download location_context 1.0.2 archive
1.0.1+1 Aug 3, 2018 Go to the documentation of location_context 1.0.1+1 Download location_context 1.0.1+1 archive
1.0.1 Jul 19, 2018 Go to the documentation of location_context 1.0.1 Download location_context 1.0.1 archive
1.0.0 Jul 17, 2018 Go to the documentation of location_context 1.0.0 Download location_context 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
16
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0