list_bloc 0.0.3 icon indicating copy to clipboard operation
list_bloc: ^0.0.3 copied to clipboard

A BLoC library for loading data from an api end-point with filtering and pagination.

1
likes
70/ 130
pub points
34%
popularity

We analyzed this package 26 days ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/apexlabs-ai/list_bloc/packages/list_bloc was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/list_bloc_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 66 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 2 possible platforms (native, js)

icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

lib/src/blocs/data_bloc.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/blocs/data_event.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^4.0.04.0.08.0.1
equatable^1.2.01.2.62.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
meta-1.7.01.7.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on bloc does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^1.2.0` on equatable does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions equatable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.1 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.1.

1
likes
70
pub points
34%
popularity

Publisher

shield icon for verified publishersapexlabs.ai

A BLoC library for loading data from an api end-point with filtering and pagination.

Homepage (missing)
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc, equatable

More

Packages that depend on list_bloc