like_sealed_gen 0.7.2+1
like_sealed_gen: ^0.7.2+1 copied to clipboard

create

2
likes
80/ 130
pub points
3%
popularity

We analyzed this package 3 days ago, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:like_sealed_gen/like_sealed_gen.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/src/content/sealed_collection_content.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/content/sealed_switch_impl_content.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=1.0.0 <2.0.01.7.22.8.0
build>=2.0.0 <2.1.02.0.32.1.1
like_sealed^0.7.00.7.00.7.0
source_gen>=1.0.0 <1.1.01.0.31.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.031.0.0
args-2.3.02.3.0
async-2.8.22.8.2
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-2.1.12.2.0
file-6.1.26.1.2
glob-2.0.22.0.2
logging-1.0.21.0.2
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pub_semver-2.1.02.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=1.0.0 <2.0.0` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `>=2.0.0 <2.1.0` on build does not support the stable version `2.1.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.