libjson2builtvalue 0.2.2

Dart native
Flutter Android iOS

Generates Dart built_value classes from given JSON. Based on https://github.com/charafau/json2builtvalue

0
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/libjson2builtvalue_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 4 API elements (25.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:libjson2builtvalue/libjson2builtvalue.dart that imports:
  • package:libjson2builtvalue/src/parser.dart that imports:
  • package:libjson2builtvalue/src/string_class.dart that imports:
  • package:dart_style/dart_style.dart that imports:
  • package:dart_style/src/exceptions.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/sdk.dart that imports:
  • package:analyzer/dart/ast/visitor.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/element/type_schema_elimination.dart that imports:
  • package:analyzer/src/dart/element/type_schema.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/lazy_ast.dart that imports:
  • package:analyzer/src/summary2/linked_unit_context.dart that imports:
  • package:analyzer/src/summary2/linked_bundle_context.dart that imports:
  • package:analyzer/src/summary2/linked_element_factory.dart that imports:
  • package:analyzer/src/dart/analysis/session.dart that imports:
  • package:analyzer/src/dart/element/inheritance_manager3.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/parser.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/string_class.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^4.2.04.3.24.3.2
code_builder^3.2.03.4.13.4.1
dart_style^1.2.71.3.71.3.7
recase^2.0.12.0.13.0.0
tuple^1.0.11.0.31.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-10.0.010.0.0
analyzer-0.40.30.40.3
args-1.6.01.6.0
async-2.4.22.4.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
fixnum-0.10.110.10.11
glob-1.2.01.2.0
js-0.6.20.6.2
matcher-0.12.90.12.9
meta-1.2.31.2.3
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pub_semver-1.4.41.4.4
quiver-2.1.32.1.3
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.1` on recase does not support the latest published version `3.0.0`

pubspec.yaml:11:11

   ╷
11 │   recase: ^2.0.1
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
0%
popularity

Generates Dart built_value classes from given JSON. Based on https://github.com/charafau/json2builtvalue

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ahmtcngvndrn@gmail.com

License

unknown (COPYING)

Dependencies

built_collection, code_builder, dart_style, recase, tuple

More

Packages that depend on libjson2builtvalue