leancloud_flutter 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 44

leancloud_flutter #

pub package

供Flutter使用的LeanCloud SDK。


使用方法 #

// (1) 先初始化
LeancloudFlutter.initialize(APP_ID, APP_KEY);

// (2) 使用平台账号登陆
var result = await LeancloudFlutter.login(username, password);

//(3) 监听消息通知
StreamSubscription _onMsgListener;
_onMsgListener = LeancloudFlutter.instance.handleOnMessage().listen((data) {

0.0.1 #

  • 初始化项目


leancloud_flutter_example #

Demonstrates how to use the leancloud_flutter plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  leancloud_flutter: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:leancloud_flutter/leancloud_flutter.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/constants.dart.

Run flutter format to format lib/constants.dart.

Format lib/doucment.dart.

Run flutter format to format lib/doucment.dart.

Format lib/leancloud_flutter.dart.

Run flutter format to format lib/leancloud_flutter.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8