leancloud_flutter 0.0.1

leancloud_flutter #

pub package

供Flutter使用的LeanCloud SDK。

目前仅供测试使用。

使用方法 #

// (1) 先初始化
LeancloudFlutter.initialize(APP_ID, APP_KEY);

// (2) 使用平台账号登陆
var result = await LeancloudFlutter.login(username, password);

//(3) 监听消息通知
StreamSubscription _onMsgListener;
_onMsgListener = LeancloudFlutter.instance.handleOnMessage().listen((data) {
    updateConversations();
});

0.0.1 #

  • 初始化项目

example/README.md

leancloud_flutter_example #

Demonstrates how to use the leancloud_flutter plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  leancloud_flutter: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:leancloud_flutter/leancloud_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Sep 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/constants.dart.

Run flutter format to format lib/constants.dart.

Format lib/doucment.dart.

Run flutter format to format lib/doucment.dart.

Format lib/leancloud_flutter.dart.

Run flutter format to format lib/leancloud_flutter.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8