ldy_radio_group 0.0.2

  • Readme
  • Changelog
  • Installing
  • 38

radio_group #

A new Flutter package project.

Radio按钮组 #

使用方法 #

    data: data,
    onChange: handleSelectingData,
    value: value,
    title: '测试RadioGroup',
// title: 组件的标题,类型:String
// data: 备选项数据, 类型:List<Map<String, dynamic>>
  data = [{
    'value': 0,
    'name': '全部'
// value: 当前选中的值,类型:num
  value = 0
// onChange: 回调函数
  onChange(item) {
    // item: 选中的数据项,类型<Map<String, dynamic>>

0.0.1 - 2019-06-04. #


0.0.2 - 2019-06-04 #


Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  ldy_radio_group: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:ldy_radio_group/custom-colors.dart';
import 'package:ldy_radio_group/radio_group.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/radio_group.dart.

Run flutter format to format lib/radio_group.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://luodongyang.dev was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and ldy_radio_group.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies