kraken_api 2.0.0-nullsafety.1
kraken_api: ^2.0.0-nullsafety.1 copied to clipboard

Dart Library for the Kraken API (https://www.kraken.com/features/api).

example/example.dart

import 'dart:convert';

import 'package:kraken_api/kraken_api.dart';

void main() {
  var api = KrakenApi('apiKey', 'secretKey');
  Future<String> response =
      api.call(Methods.TRADE_BALANCE, parameters: {'asset': 'ZEUR'});

  response.then(
    (body) {
      Map<String, dynamic> tradeBalances = jsonDecode(body)['result'];
      return tradeBalances;
    },
  );
}
3
likes
130
pub points
34%
popularity

Publisher

begnis.dev

Dart Library for the Kraken API (https://www.kraken.com/features/api).

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

crypto, http

More

Packages that depend on kraken_api