kana 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • new57

kana #

kana to romaji convertion for dart

version 1.0.0

add data for kana without Digraphs and Diacritics

Version 0.0.3

corrects folder name for examples

Version 0.0.2

add exemple

Version 0.0.1

add function getKatakana

add function getRomajiFromKatakana

add function getHiragana

add function getRomajiFromHiragana

add data with only the a character

example/main.dart

import 'package:kana/kana.dart';

void main() {
  final r = "shi";
  final h = "ゆ";
  final k = "ア";
  print("Hiragana ${getHiragana(r)} from Romaji $r");
  print("Katakana ${getKatakana(r)} from Romaji $r");
  print("Romaji ${getRomajiFromHiragana(h)} from Hiragana $h");
  print("Romaji ${getRomajiFromKatakana(k)} from Katakana $k");
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  kana: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:kana/kana.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Oct 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:kana/kana.dart.

Health issues and suggestions

Document public APIs. (-1 points)

9 out of 9 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0