jsproxy 1.0.0

#JsProxy #

Creates a JavaScript interface for a dart project so that a dart library can be easily used from JavaScript world.

[Experimental] It is at a very early stage today. The user needs to specify a conversion function to expose dart library (Please see test.dart as an example). The goal of this project is to provide an annotation and an transformer which auto generate a javascript interface for a dart library.

0.0.6 #

  • Fix function conversion

0.0.5 #

  • In createJsProxy function, it the obj is not coverred by any case, return a JsProxy.

0.0.4 #

  • Fix stack overflow

0.0.3 #

  • pass customConversionFunc into futureProxy

0.0.2 #

  • Add isFuture in FutureProxy

0.0.1 #

  • Initial implementation

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jsproxy: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jsproxy/jsproxy.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

We analyzed this package on Aug 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.4.0.
 
 Because jsproxy requires SDK version >=1.0.0 <2.0.1, version solving failed.

Health suggestions

Format lib/src/js_future_proxy.dart.

Run dartfmt to format lib/src/js_future_proxy.dart.

Format lib/src/js_object_proxy.dart.

Run dartfmt to format lib/src/js_object_proxy.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support the latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Package is getting outdated. (-47.12 points)

The package was last published 76 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and jsproxy.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.1