- Fix function conversion
- In createJsProxy function, it the obj is not coverred by any case, return a JsProxy.
- Fix stack overflow
- pass customConversionFunc into futureProxy
- Add isFuture in FutureProxy
- Initial implementation
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: jsproxy: ^1.0.0
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.0
- pana: 0.13.4
Analysis issues and suggestions
Fix dependencies in
pub upgrade failed with the following output:
ERR: The current Dart SDK version is 2.7.0. Because jsproxy requires SDK version >=1.0.0 <2.0.1, version solving failed.
dartfmt to format
dartfmt to format
Maintenance issues and suggestions
Support future stable Dart 2 SDKs in
pubspec.yaml. (-20 points)
The SDK constraint in
pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.
No valid SDK. (-20 points)
The analysis could not detect a valid SDK that can use this package.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
Package is getting outdated. (-89.59 points)
The package was last published 98 weeks ago.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
jsproxy.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=1.0.0 <2.0.1|