jaguar_mustache 0.5.0

jaguar_mustache #

Jaguar interceptors to render mustache templates

Example #

@Api(path: '/api')
class ExampleApi extends _$JaguarExampleApi {
  @Get(path: '/file')
  Future<Map<String, String>> mustacheFile() async {
    return {'login': 'Kleak'};

  @Get(path: '/str')
  Future<Map<String, String>> mustacheStr() async {
    return {'login': 'Kleak'};

Changelog #

0.0.1 #

  • Interceptor to render mustache templates from file and string


/// File: main.dart
library jaguar.example;

import 'dart:async';
import 'package:jaguar/jaguar.dart';
import 'package:jaguar_mustache/jaguar_mustache.dart';

const String kTemplate = r"<h1>{{login}}</h1>";

@Api(path: '/api')
class ExampleApi {
  MustacheRender fileRenderer(_) =>
      new MustacheRender('example/test.template.html');

  MustacheStrRender strRenderer(_) => new MustacheStrRender(kTemplate);

  @Get(path: '/file')
  Future<Map<String, String>> mustache(_) async {
    return {'login': 'Kleak'};

  @Get(path: '/str')
  Future<Map<String, String>> mustacheStr(_) async {
    return {'login': 'Kleak'};

Future<Null> main(List<String> args) async {
  final server = new Jaguar();
  server.addApiReflected(new ExampleApi());
  await server.serve();

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jaguar_mustache: ^0.5.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:jaguar_mustache/jaguar_mustache.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0