install_plugin 0.0.1

  • Example
  • Installing
  • Versions
  • 86

install_plugin #

A flutter plugin for install apk for android; and using url to go to app store for iOS.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.1 #

  • TODO: Describe initial release.


import 'dart:async';

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:install_plugin/install_plugin.dart';
import 'package:permission_handler/permission_handler.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  _MyAppState createState() => new _MyAppState();

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  void initState() {

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await InstallPlugin.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;

  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Plugin example app'),
        body: new Column(
          children: <Widget>[
                onPressed: () {
                child: Text('install')),
            FlatButton(onPressed: (){
            }, child: Text('gotoAppStore'))

  void onClickInstallApk() {
    requestPermission( {
      print('requestPermission result: $result');
      if (result[] == PermissionStatus.granted) {
            .then((result) {
          print('install apk $result');
        }).catchError((error) {
          print('install apk error: $error');
      } else {}
    }).catchError((error) {
      print('requestPermission error: $error');

  void onClickGotoAppStore() {
  Future<Map<PermissionGroup, PermissionStatus>> requestPermission(
      PermissionGroup permission) async {
    final List<PermissionGroup> permissions = <PermissionGroup>[permission];
    return await PermissionHandler().requestPermissions(permissions);


Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  install_plugin: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:install_plugin/install_plugin.dart';
Version Uploaded Documentation Archive
2.0.1 May 16, 2019 Go to the documentation of install_plugin 2.0.1 Download install_plugin 2.0.1 archive
2.0.0 Mar 28, 2019 Go to the documentation of install_plugin 2.0.0 Download install_plugin 2.0.0 archive
1.2.0 Feb 14, 2019 Go to the documentation of install_plugin 1.2.0 Download install_plugin 1.2.0 archive
1.0.0 Dec 11, 2018 Go to the documentation of install_plugin 1.0.0 Download install_plugin 1.0.0 archive
0.0.2 Sep 25, 2018 Go to the documentation of install_plugin 0.0.2 Download install_plugin 0.0.2 archive
0.0.1 Sep 23, 2018 Go to the documentation of install_plugin 0.0.1 Download install_plugin 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on May 30, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.17
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
permission_handler ^2.0.0 2.2.0 3.1.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8