inject_assets_builder 1.0.0+1

Dart native
Flutter Android iOS

A builder that makes it possible for a package to access files from packages depending on it.

0
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Oct 29, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 10 API elements (30.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:inject_assets_builder/builder.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build>=0.12.7 <2.0.01.5.01.5.0
build_config^0.3.1+30.3.20.4.2
meta>=0.9.0 <2.0.01.2.31.2.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.012.0.0
analyzer-0.40.50.40.5
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
glob-1.2.01.2.0
js-0.6.20.6.2
json_annotation-2.4.03.1.0
logging-0.11.40.11.4
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.1+3` on build_config does not support the latest published version `0.4.2`

pubspec.yaml:12:17

   ╷
12 │   build_config: ^0.3.1+3
   │                 ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
0%
popularity

A builder that makes it possible for a package to access files from packages depending on it.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

philippschiffmann93@gmail.com

License

MIT (LICENSE)

Dependencies

build, build_config, meta

More

Packages that depend on inject_assets_builder