indzooom_android_downloader 1.0.4+1

Indzooom Android Downloader #


indzooom_android_downloader - A plugin that calls the Android download manager 一个调用安卓系统下载管理器的插件

首先 / First of all #

在您的android / app / AndroidManifest.xml上添加以下内容: / On your android/app/AndroidManifest.xml add this #

    <uses-permission android:name="android.permission.WAKE_LOCK" />
    <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
    <uses-permission android:name="android.permission.INTERNET" />
    <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />
    <uses-permission android:name="android.permission.READ_PHONE_STATE" />

添加依赖 / Add Dependency #

  indzooom_android_downloader: ^1.0.4+1

创建下载 / Create a download #"url", "path", "fileName");

参数说明 / Parameter description

  • url: 下载地址 / download link

  • path: 下载路径,目前只能保存在SD卡目下,比如保存到SD卡A根目录就填写/A / The download path can only be saved under the SD card. For example, if you save it to the root directory of the SD card, fill in / A.

  • fileName: 保存的文件名称 / Saved file name

使用的示例 / Examples of use #

import 'package:flutter/material.dart';
import 'package:indzooom_android_downloader/indzooom_android_downloader.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  _MyAppState createState() => _MyAppState();

class _MyAppState extends State<MyApp> {
  void initState() {

  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        body: Center(
          child: IconButton(
            icon: Icon(Icons.file_download),
            onPressed: () {

1.0.4+1 #

  • A newest approach

1.0.2+3 #

  • Adjust some errors on the published version (upload problem)

1.0.2+2 #

  • Adjust some errors on the published version (upload problem)

1.0.1+2 #

  • Publish release

0.0.1+2 #

  • update

0.0.1 #

  • initial release.


indzooom_android_downloader_example #

Demonstrates how to use the indzooom_android_downloader plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  indzooom_android_downloader: ^1.0.4+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:indzooom_android_downloader/indzooom_android_downloader.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health issues and suggestions

Document public APIs. (-1 points)

6 out of 6 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/indzooom_android_downloader.dart.

Run flutter format to format lib/indzooom_android_downloader.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The description is too long. (-2 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies