indonesian_currency_formatter 0.0.5+2

Warning: experimental, use for my personal purpose #

indonesian_currency_formatter #

Indonesian rupiah currency formatter, currency parser and input formatter.

indonesian_currency_formatter: ^0.0.5

TODO #

  • [ ] Add more tests (to create other functionality)

[0.0.5+2] - January 18th, 2020.

  • Add max value.

[0.0.5+1] - January 17th, 2020.

  • Fix failed test.

[0.0.4] - January 16th, 2020.

  • Add specific function for using options.

[0.0.3] - January 16th, 2020.

  • Add commaDelimiter and thousandDelimiter.

[0.0.2] - December 15th, 2019.

  • Add basic tests.

[0.0.1] - TODO: Add release date.

  • Add basic parsing, formatting and inputFormatter

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  indonesian_currency_formatter: ^0.0.5+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:indonesian_currency_formatter/indonesian_currency_formatter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
37
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Feb 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and indonesian_currency_formatter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
intl ^0.16.0 0.16.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test