id4me_relying_party_api 0.5.1
id4me_relying_party_api: ^0.5.1 copied to clipboard

This library provides the functionalities necessary to implement the Id4me login process.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Feb 23, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 45 out of 247 API elements (18.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: Too many positional arguments: 1 expected, but 2 found.

lib/src/Id4meLogon.dart:305:39

    ╷
305 │     return await HttpUtils.postForJson(url, body, headers: headers);
    │                                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/Id4meLogon.dart

ERROR: Too many positional arguments: 1 expected, but 2 found.

lib/src/Id4meLogon.dart:356:41

    ╷
356 │         return await HttpUtils.postForJson(url, '',
    │ ┌─────────────────────────────────────────^
357 │ │           queryParameters: parameters, headers: headers);
    │ └────────────────────────────────────────────────────────^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/Id4meLogon.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
basic_utils^2.4.52.7.12.7.1
crypto^2.0.62.1.53.0.0
jose^0.1.20.1.2+10.2.2
logging^0.11.3+20.11.41.0.0
uuid^2.0.12.2.23.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto_keys-0.1.40.1.4
http-0.12.20.13.0
http_parser-3.1.44.0.0
json_annotation-3.1.14.0.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
pointycastle-2.0.12.0.1
quiver-2.1.53.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.0.6` on crypto does not support the latest published version `3.0.0`

pubspec.yaml:16:11

   ╷
16 │   crypto: ^2.0.6
   │           ^^^^^^
   ╵
The constraint `^0.1.2` on jose does not support the latest published version `0.2.2`

pubspec.yaml:15:9

   ╷
15 │   jose: ^0.1.2
   │         ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.12.0-133.2.beta.

0
likes
60
pub points
0%
popularity

This library provides the functionalities necessary to implement the Id4me login process.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

aic7to@gmail.com

License

unknown (LICENSE)

Dependencies

basic_utils, crypto, jose, logging, uuid

More

Packages that depend on id4me_relying_party_api