iconpacks 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • new57

iconpacks #

An interface for Android developers to interact with Icon Packs installed on a users device.

Getting Started #

IconPacks.iconPacks & IconPacks.getIcon(String packageName, String iconPackPackageName, {width, height})

PLUGIN DOES NOT CACHE IMAGES FOR YOU, BE SURE TO CACHE IMAGES & SAVE THEM TO IMPROVE LOADING TIMES, this plugin is meant to be used in conjunction with any of the plugins that can acquire a list of application packages.

0.0.3 #

Added getRawIcon method which returns Uint8List

0.0.2 #

Null pointer exception when icon pack had no icon for a package

0.0.1 #

Initial release

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:iconpacks/iconpacks.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';
  String iconPacks = "";
  Widget spotifyIcon = Container();
  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await IconPacks.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }
    List iconPacks = await IconPacks.iconPacks;
    this.iconPacks = iconPacks.toString();
    spotifyIcon = await IconPacks.getIcon("com.spotify.music", iconPacks[0]);

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    List<Widget> content = [
      Text('Running on: $_platformVersion\n'),
    ];
    content.add(Text(iconPacks));
    content.add(spotifyIcon);
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin: Icon_Packs'),
        ),
        body: Center(
          child: Column(
            children: content
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  iconpacks: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:iconpacks/iconpacks.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on May 30, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev
  • Flutter: 1.17.1

Health issues and suggestions

Document public APIs. (-1 points)

7 out of 7 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/iconpacks.dart.

Run flutter format to format lib/iconpacks.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test