human_anatomy 0.0.2
human_anatomy: ^0.0.2 copied to clipboard

A new Flutter package for Human Anatomy.

25 / 110
pub points
54 %

We analyzed this package on Apr 13, 2021, and awarded it 25 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid

Links in `` should be secure. 1 image link is insecure.

4 │ <h2>Demo</h2><img src="" width="340" height="640" title="Screen Shoot">
  │              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Use https URLs instead.

5/5 points: Provide a valid

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: Documenting human_anatomy...
Initialized dartdoc with 752 libraries in 98.3 seconds
Generating docs for library human_anatomy from package:human_anatomy/full_page_human_anatomy.dart...
Generating docs for library human_anatomy from package:human_anatomy/human_anatomy.dart...
Generating docs for library utils from package:human_anatomy/utils.dart...
Documented 3 public libraries in 4.2 seconds
stderr:   warning: human_anatomy has no library level documentation comments, from human_anatomy: (file:///tmp/pub-dartlang-dartdocHFWHNE/pkg/lib/full_page_human_anatomy.dart:1:9)
  warning: human_anatomy has no library level documentation comments, from human_anatomy: (file:///tmp/pub-dartlang-dartdocHFWHNE/pkg/lib/human_anatomy.dart:1:9)
  error: failed to write file at: human_anatomy/human_anatomy-library.html
    for symbol human_anatomy: (file:///tmp/pub-dartlang-dartdocHFWHNE/pkg/lib/human_anatomy.dart:1:9)
    conflicting with file already generated by human_anatomy: (file:///tmp/pub-dartlang-dartdocHFWHNE/pkg/lib/full_page_human_anatomy.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            human_anatomy conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
Found 2 warnings and 1 error.
Unhandled exception:
encountered 1 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:225:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:21:19)
<asynchronous suspension>

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web


  • package:human_anatomy/human_anatomy.dart that imports:
  • package:flutter_svg/flutter_svg.dart that imports:
  • package:flutter_svg/svg.dart that imports:
  • package:flutter_svg/src/vector_drawable.dart that imports:
  • package:flutter_svg/src/svg/parsers.dart that imports:
  • package:flutter_svg/src/utilities/http.dart that imports:
  • dart:io
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

ERROR: The named parameter 'child' isn't defined.


11 │         child: new CupertinoAlertDialog(
   │         ^^^^^

To reproduce make sure you are using pedantic and run flutter analyze lib/utils.dart

WARNING: The parameter 'builder' is required.


8 │     showDialog(
  │     ^^^^^^^^^^

To reproduce make sure you are using pedantic and run flutter analyze lib/utils.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

Transitive dependencies

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on flutter_svg does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.