Over time this should become a collection of useful HTTP-Tools...
If the documenation links don't not work - pls. got to GitHub - there it they'll work
Commonly used status codes defined by HTTP
Dart Documentation for ResponseStatus here
Helps you to compose URIs.
Dart Documentation for URIBuilder here
http_utils on PUB
Copyright 2016 Michael Mitterer, IT-Consulting and Development Limited, Austrian Branch Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.
If this plugin is helpful for you - please (Circle) me.
Change Log for http_utils #
Provides some HTTP related classes portet from Apache HTTP client lib
- Preparation for Jenkins, versions constraints 53e6002
v1.4.1 - 2016-11-16
- Strong-Mode support a27801b
v1.4.0 - 2015-12-04
- Grinder-Support + new test-format 373cb68
This CHANGELOG.md was generated with Changelog for Dart
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: http_utils: ^1.5.1
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Analysis issues and suggestions
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
Maintenance issues and suggestions
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.12.0 <2.0.0|