http_server 0.9.8

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 81

Utility classes for HTTP server #

A set of high-level classes that, together with HttpServer, makes is easier to serve web content.

NOTE: This package only works for server-side or command-line Dart applications. In other words, if the app imports dart:io, it can use this package.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.9.8 #

  • Updates to support Dart 2 constants.

0.9.7 #

  • Updates to support Dart 2.0 core library changes (wave 2.2). See issue 31847 for details.

0.9.6 #

  • Updated the secure networking code to the SDKs version 1.15 SecurityContext api

0.9.5+1 #

  • Updated the layout of package contents.

0.9.5 #

  • Removed the decoding of HTML entity values (in the form &#xxxxx;) for values when parsing multipart/form-post requests.

0.9.4 #

  • Fixed bugs in the handling of the Range header

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_server: ^0.9.8

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_server/http_server.dart';
  
Version Uploaded Documentation Archive
0.9.8+1 Nov 5, 2018 Go to the documentation of http_server 0.9.8+1 Download http_server 0.9.8+1 archive
0.9.8 Jul 11, 2018 Go to the documentation of http_server 0.9.8 Download http_server 0.9.8 archive
0.9.7 Feb 2, 2018 Go to the documentation of http_server 0.9.7 Download http_server 0.9.7 archive
0.9.6 Aug 18, 2016 Go to the documentation of http_server 0.9.6 Download http_server 0.9.6 archive
0.9.5+1 Nov 24, 2014 Go to the documentation of http_server 0.9.5+1 Download http_server 0.9.5+1 archive
0.9.5 Nov 19, 2014 Go to the documentation of http_server 0.9.5 Download http_server 0.9.5 archive
0.9.4 Nov 17, 2014 Go to the documentation of http_server 0.9.4 Download http_server 0.9.4 archive
0.9.3 Jul 30, 2014 Go to the documentation of http_server 0.9.3 Download http_server 0.9.3 archive
0.9.2+3 Jul 24, 2014 Go to the documentation of http_server 0.9.2+3 Download http_server 0.9.2+3 archive
0.9.2+2 Jul 4, 2014 Go to the documentation of http_server 0.9.2+2 Download http_server 0.9.2+2 archive

All 55 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
86
Health:
Code health derived from static analysis. [more]
81
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15

Platforms

Detected platforms: Flutter, other

Primary library: package:http_server/http_server.dart with components: io.

Health suggestions

Fix lib/src/http_body.dart. (-8.63 points)

Analysis of lib/src/http_body.dart reported 18 hints, including:

line 13 col 1: Prefer using /// for doc comments.

line 102 col 3: Prefer using /// for doc comments.

line 111 col 44: Use = to separate a named parameter from its default value.

line 114 col 3: Prefer using /// for doc comments.

line 121 col 32: Use = to separate a named parameter from its default value.

Fix lib/src/http_multipart_form_data.dart. (-4.41 points)

Analysis of lib/src/http_multipart_form_data.dart reported 9 hints, including:

line 15 col 1: Prefer using /// for doc comments.

line 34 col 3: Prefer using /// for doc comments.

line 40 col 3: Prefer using /// for doc comments.

line 47 col 3: Prefer using /// for doc comments.

line 54 col 3: Prefer using /// for doc comments.

Fix lib/src/virtual_directory.dart. (-4.41 points)

Analysis of lib/src/virtual_directory.dart reported 9 hints, including:

line 22 col 1: Prefer using /// for doc comments.

line 32 col 3: Prefer using /// for doc comments.

line 38 col 3: Prefer using /// for doc comments.

line 44 col 3: Prefer using /// for doc comments.

line 81 col 3: Prefer using /// for doc comments.

Fix lib/src/virtual_host.dart. (-2.48 points)

Analysis of lib/src/virtual_host.dart reported 5 hints:

line 10 col 1: Prefer using /// for doc comments.

line 15 col 3: Prefer using /// for doc comments.

line 21 col 3: Prefer using /// for doc comments.

line 38 col 3: Prefer using /// for doc comments.

line 43 col 3: Prefer using /// for doc comments.

Fix lib/http_server.dart. (-0.50 points)

Analysis of lib/http_server.dart reported 1 hint:

line 5 col 1: Prefer using /// for doc comments.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and http_server.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.61.0 <3.0.0
mime >=0.9.0 <0.10.0 0.9.6+2
path >=0.9.0 <2.0.0 1.6.2
Dev dependencies
test ^1.2.0