http_server 0.9.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 43

Utility classes for HTTP server #

A set of high-level classes that, together with HttpServer, makes is easier to serve web content.

NOTE: This package only works for server-side or command-line Dart applications. In other words, if the app imports dart:io, it can use this package.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.9.7 #

  • Updates to support Dart 2.0 core library changes (wave 2.2). See issue 31847 for details.

0.9.6 #

  • Updated the secure networking code to the SDKs version 1.15 SecurityContext api

0.9.5+1 #

  • Updated the layout of package contents.

0.9.5 #

  • Removed the decoding of HTML entity values (in the form &#xxxxx;) for values when parsing multipart/form-post requests.

0.9.4 #

  • Fixed bugs in the handling of the Range header

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_server: ^0.9.7

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_server/http_server.dart';
  
Version Uploaded Documentation Archive
0.9.8+1 Nov 5, 2018 Go to the documentation of http_server 0.9.8+1 Download http_server 0.9.8+1 archive
0.9.8 Jul 11, 2018 Go to the documentation of http_server 0.9.8 Download http_server 0.9.8 archive
0.9.7 Feb 2, 2018 Go to the documentation of http_server 0.9.7 Download http_server 0.9.7 archive
0.9.6 Aug 18, 2016 Go to the documentation of http_server 0.9.6 Download http_server 0.9.6 archive
0.9.5+1 Nov 24, 2014 Go to the documentation of http_server 0.9.5+1 Download http_server 0.9.5+1 archive
0.9.5 Nov 19, 2014 Go to the documentation of http_server 0.9.5 Download http_server 0.9.5 archive
0.9.4 Nov 17, 2014 Go to the documentation of http_server 0.9.4 Download http_server 0.9.4 archive
0.9.3 Jul 30, 2014 Go to the documentation of http_server 0.9.3 Download http_server 0.9.3 archive
0.9.2+3 Jul 24, 2014 Go to the documentation of http_server 0.9.2+3 Download http_server 0.9.2+3 archive
0.9.2+2 Jul 4, 2014 Go to the documentation of http_server 0.9.2+2 Download http_server 0.9.2+2 archive

All 55 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
86
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.20.0 <2.0.0