A set of high-level classes that, together with
HttpServer, makes is easier to serve web content.
NOTE: This package only works for server-side or command-line Dart
applications. In other words, if the app imports
dart:io, it can use this
Please file feature requests and bugs at the issue tracker.
Updates to support Dart 2.0 core library changes (wave 2.2). See issue 31847 for details.
Add this to your package's pubspec.yaml file:
dependencies: http_server: ^0.9.7
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.9.8+1||Nov 5, 2018|
|0.9.8||Jul 11, 2018|
|0.9.7||Feb 2, 2018|
|0.9.6||Aug 18, 2016|
|0.9.5+1||Nov 24, 2014|
|0.9.5||Nov 19, 2014|
|0.9.4||Nov 17, 2014|
|0.9.3||Jul 30, 2014|
|0.9.2+3||Jul 24, 2014|
|0.9.2+2||Jul 4, 2014|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=2.0.0-dev.20.0 <2.0.0|