http_request_proxy 0.0.2

  • Installing
  • Versions
  • 0

HTTP request proxy #

Proxy HTTP requests to other server (typically from Dart backend to pub serve during development).

Usage #

A simple usage example:

import 'dart:io';
import 'package:http_request_proxy/http_request_proxy.dart';

main() {
  var proxy = new HttpRequestProxy('localhost', 8000);
  HttpServer server = await HttpServer.bind(InternetAddress.ANY_IP_V4, 3333);
  server.listen((request) {
    if (request.uri.path.startsWith('/api/')) {
      // handle API call
    } else {
      // proxy to local pub serve

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  http_request_proxy: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:http_request_proxy/http_request_proxy.dart';
Version Uploaded Documentation Archive
0.0.2 Nov 12, 2016 Go to the documentation of http_request_proxy 0.0.2 Download http_request_proxy 0.0.2 archive
0.0.1 Nov 5, 2016 Go to the documentation of http_request_proxy 0.0.1 Download http_request_proxy 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0