hots_dog_api 1.2.3

hots.dog API #

The hots.dog API provides Heroes of Storm statistical information. This package provides a Dart library for using those APIs.

Changelog #

1.2.3 #

  • Fix issues with Dart 2 type casting

1.2.2 #

  • Place an upper bound on Dart version support

1.2.1 #

  • Fixed an issue with type inference

1.2.0: #

  • Dart 2 support

example/example.dart

import 'package:hots_dog_api/hots_dog_api.dart';

main() async {
  try {
    BuildWinRates buildWinRates = await getBuildWinRates('2.30.0', 'Rehgar');
    print(buildWinRates);

  } catch (e) {
    print(e);
  }

  try {
    WinRates winRates = await getWinRates('2.30.0');
    print(winRates);

  } catch (e) {
    print(e);
  }

  try {
    GameInfo gameInfo = await getGameInfo();
    print(gameInfo);
  } catch (e) {
    print(e);
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hots_dog_api: ^1.2.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hots_dog_api/hots_dog_api.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Aug 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:hots_dog_api/hots_dog_api.dart.

Health suggestions

Fix lib/src/model/win_loss_count.dart. (-1 points)

Analysis of lib/src/model/win_loss_count.dart reported 2 hints:

line 5 col 16: Don't type annotate initializing formals.

line 5 col 31: Don't type annotate initializing formals.

Format lib/src/api.dart.

Run dartfmt to format lib/src/api.dart.

Format lib/src/model/build_info.dart.

Run dartfmt to format lib/src/model/build_info.dart.

Fix additional 8 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/model/build_statistics.dart (Run dartfmt to format lib/src/model/build_statistics.dart.)
  • lib/src/model/build_win_rates.dart (Run dartfmt to format lib/src/model/build_win_rates.dart.)
  • lib/src/model/game_info.dart (Run dartfmt to format lib/src/model/game_info.dart.)
  • lib/src/model/hero_info.dart (Run dartfmt to format lib/src/model/hero_info.dart.)
  • lib/src/model/talent.dart (Run dartfmt to format lib/src/model/talent.dart.)
  • lib/src/model/talent_win_rate.dart (Run dartfmt to format lib/src/model/talent_win_rate.dart.)
  • lib/src/model/win_rates.dart (Run dartfmt to format lib/src/model/win_rates.dart.)
  • lib/src/utils.dart (Run dartfmt to format lib/src/utils.dart.)

Maintenance suggestions

The package description is too short. (-15 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
collection ^1.14.11 1.14.12
http ^0.12.0 0.12.0+2
Transitive dependencies
async 2.3.0
charcode 1.1.2
http_parser 3.1.3
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6