hestia_navigation 0.3.0

Hestia Navigation libraries for Dart on the server and flutter

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hestia_navigation: ^0.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hestia_navigation/hestia_navigation.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
55
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:hestia_navigation/hestia_navigation.dart.

Health issues and suggestions

Fix lib/src/client_stub.dart. (-43.75 points)

Analysis of lib/src/client_stub.dart failed with 2 errors:

line 1 col 8: The name 'NavigationResponse' isn't a type so it can't be used as a type argument.

line 2 col 15: Undefined class 'NavigationRequest'.

Fix lib/src/hestia_server.dart. (-0.50 points)

Analysis of lib/src/hestia_server.dart reported 1 hint:

line 8 col 3: This function has a return type of 'Future

Fix lib/src/io_client.dart. (-0.50 points)

Analysis of lib/src/io_client.dart reported 1 hint:

line 17 col 3: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

Fix additional 4 files with analysis or formatting issues. (-0.50 points)

Additional issues in the following files:

  • lib/src/web_client.dart (1 hint)
  • lib/src/navigation.pb.dart (Run dartfmt to format lib/src/navigation.pb.dart.)
  • lib/src/navigation.pbenum.dart (Run dartfmt to format lib/src/navigation.pbenum.dart.)
  • lib/src/navigation.pbjson.dart (Run dartfmt to format lib/src/navigation.pbjson.dart.)

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (protobuf).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and hestia_navigation.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
async ^2.3.0 2.4.0
grpc ^2.1.2 2.1.2
hestia_core ^0.2.0 0.2.0
protobuf ^0.14.1 0.14.4 1.0.0
Transitive dependencies
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.3
fixnum 0.10.9
googleapis_auth 0.2.10
http 0.12.0+2
http2 1.0.0
http_parser 3.1.3
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
test ^1.6.9