hestia 0.1.1

hestia library

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  hestia: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:hestia/gen/navigation.pbenum.dart';
import 'package:hestia/gen/navigation.pbjson.dart';
import 'package:hestia/gen/navigation.pb.dart';
import 'package:hestia/gen/navigation.pbgrpc.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on May 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev

Health issues and suggestions

Fix lib/gen/navigation.pb.dart. (-99.25 points)

Analysis of lib/gen/navigation.pb.dart failed with 16 errors, 60 hints, including:

line 99 col 24: Too many positional arguments: 3 expected, but 5 found.

line 101 col 23: Too many positional arguments: 3 expected, but 5 found.

line 154 col 32: Too many positional arguments: 3 expected, but 5 found.

line 228 col 28: Too many positional arguments: 3 expected, but 5 found.

line 230 col 14: Too many positional arguments: 3 expected, but 4 found.

Fix lib/gen/navigation.pbjson.dart. (-25 points)

Analysis of lib/gen/navigation.pbjson.dart reported 61 hints, including:

line 7 col 29: Avoid const keyword.

line 9 col 8: Avoid const keyword.

line 10 col 5: Avoid const keyword.

line 11 col 5: Avoid const keyword.

line 15 col 28: Avoid const keyword.

Fix lib/gen/navigation.pbgrpc.dart. (-2.96 points)

Analysis of lib/gen/navigation.pbgrpc.dart reported 6 hints, including:

line 14 col 27: Unnecessary new keyword.

line 17 col 28: Unnecessary new keyword.

line 25 col 19: Unnecessary new keyword.

line 27 col 12: Unnecessary new keyword.

line 35 col 16: Unnecessary new keyword.

Format lib/gen/navigation.pbenum.dart.

Run dartfmt to format lib/gen/navigation.pbenum.dart.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: protobuf.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://hestiaio.com was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (grpc).

Package is getting outdated. (-22.74 points)

The package was last published 64 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and hestia.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
async >=1.13.3 <3.0.0 2.4.1
grpc ^1.0.1 1.0.3 2.1.3
protobuf any 1.0.1
Transitive dependencies
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.5
fixnum 0.10.11
googleapis_auth 0.2.11+1
http 0.12.1
http2 1.0.0
http_parser 3.1.4
meta 1.1.8
path 1.7.0
pedantic 1.9.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
test ^1.3.0