happypass_builder 1.0.4

1.0.0 #

  • HappyPass 请求构造器基本完成

1.0.1 #

  • 优化代码结构

1.0.2 #

  • 修正注释...

1.0.3 #

  • 忽略 RawChannel 返回值检查

1.0.4 #

  • 新增对 RequestClosable 的支持

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  happypass_builder: ^1.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:happypass_builder/happypass_builder.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
71
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Health suggestions

Format lib/builder.dart.

Run dartfmt to format lib/builder.dart.

Format lib/happypass_builder.dart.

Run dartfmt to format lib/happypass_builder.dart.

Format lib/src/annotations.dart.

Run dartfmt to format lib/src/annotations.dart.

Format lib/src/builder.dart.

Run dartfmt to format lib/src/builder.dart.

Maintenance suggestions

The package description is too short. (-19 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and happypass_builder.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
analyzer >=0.39.0 <0.40.0 0.39.12
build ^1.0.0 1.3.0
path ^1.6.0 1.7.0
Transitive dependencies
_fe_analyzer_shared 5.0.0
args 1.6.0
async 2.4.2
charcode 1.1.3
collection 1.14.13 1.15.0-nnbd
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
glob 1.2.0
html 0.14.0+3
js 0.6.2
logging 0.11.4
meta 1.2.1
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
pub_semver 1.4.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0 1.3.0-nnbd
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
build_runner ^1.0.0
pedantic ^1.8.0 1.9.1
test ^1.6.0