haiku 1.0.5

  • README.md
  • Installing
  • Versions
  • 0

Haiku #

Detect and create Haikus

Examples #

Detecting a haiku #

final poem = '''
   This is my long poem. It is too long for haiku, because it's tail is quite large.
''';

final haikuPoem = '''
    An old silent pond... A frog jumps into the pond, splash! Silence again.
''';

print(Haiku.isHaiku(poem); // False; 19 syllables
print(Haiku.isHaiku(haikuPoem); // True

Creating a Haiku #

final haiku = Haiku.create(haikuPoem);
print(haiku.firstLine); // ['An', 'old', 'silent', 'pond...'];
print(haiku.thirdLine); // ['splash!', 'Silence', 'again.'];

Printing a Haiku #

print(const CitationFormatter('You').format(haiku));

//  *An old silent pond...
//  A frog jumps into the pond,
//  splash! Silence again.*
//      - You

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  haiku: ^1.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:haiku/haiku.dart';
  
Version Uploaded Documentation Archive
1.0.6 Oct 6, 2017 Go to the documentation of haiku 1.0.6 Download haiku 1.0.6 archive
1.0.5 Oct 6, 2017 Go to the documentation of haiku 1.0.5 Download haiku 1.0.5 archive
1.0.4 Oct 6, 2017 Go to the documentation of haiku 1.0.4 Download haiku 1.0.4 archive
1.0.3 Oct 6, 2017 Go to the documentation of haiku 1.0.3 Download haiku 1.0.3 archive
1.0.2 Oct 6, 2017 Go to the documentation of haiku 1.0.2 Download haiku 1.0.2 archive
1.0.1 Oct 5, 2017 Go to the documentation of haiku 1.0.1 Download haiku 1.0.1 archive
1.0.0 Oct 4, 2017 Go to the documentation of haiku 1.0.0 Download haiku 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.