hacker_news_client 0.1.0

hacker_news_client #

Build Status codecov

A Dart client for the Hacker News API. Works on Flutter, Server, and Web.

Usage #

No need for an API key or anything, just create an instance of the client and fetch results!

// Create a client and pass in an http.Client.
//   - For Flutter & Server, use IOClient
//   - For Web, use BrowserClient
final client = HackerNewsClient(IOClient());

// Fetch the top stories. Does not include all comments.
final topStories = await client.topStories();

// Fetch the newest stories. Does not include all comments
final newStories = await client.newStories();

// Fetch a story with all comments
final newStories = await client.story(8863);

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.1.0 #

  • Initial version of a a Hacker News Client for Dart
  • Works on Flutter, Server, and Web
  • Covered by tests
  • Supports:
    • Top Stories
    • Best Stories
    • New Stories
    • Jobs
    • Ask Hacker News
    • Show Hacker News
    • Story with all comments
    • Poll with Options and all comments
    • User

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hacker_news_client: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hacker_news_client/hacker_news_client.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
17
Health:
Code health derived from static analysis. [more]
74
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
44
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Sep 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:hacker_news_client/hacker_news_client.dart.

Health issues and suggestions

Fix lib/src/client.dart. (-25 points)

Analysis of lib/src/client.dart failed with 1 error:

line 74 col 30: The constructor 'List.generate' doesn't have type parameters.

Fix lib/src/models/poll.g.dart. (-0.50 points)

Analysis of lib/src/models/poll.g.dart reported 1 hint:

line 184 col 7: DO use curly braces for all flow control structures.

Fix lib/src/models/poll_option.g.dart. (-0.50 points)

Analysis of lib/src/models/poll_option.g.dart reported 1 hint:

line 131 col 7: DO use curly braces for all flow control structures.

Maintenance issues and suggestions

Support latest dependencies. (-30 points)

The version constraint in pubspec.yaml does not support the latest published versions for 3 dependencies (built_collection, built_value, http).

Package is getting outdated. (-15.62 points)

The package was last published 60 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and hacker_news_client.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.50.0 <3.0.0
built_collection ^3.1.1 3.1.3 4.2.2
built_value ^5.5.3 5.5.5 6.7.1
http ^0.11.3+17 0.11.3+17 0.12.0+2
Transitive dependencies
async 2.3.0
charcode 1.1.2
collection 1.14.12
fixnum 0.10.9
http_parser 3.1.3
matcher 0.12.5
meta 1.1.7
path 1.6.4
quiver 2.0.5
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
build_runner ^0.9.0
built_value_generator ^5.5.3
coverage 0.12.1
test ^1.0.0